This topic is locked.

Blacklist doesn't work
Blacklisting doesn't work.

F.e. when I put these tags on the black list, they still show up in the search result.


Why is that ?
First of all, yaoi, dereyoruk and octopus are not valid tags here. Since there are no posts with those tags, posts with those tags are NOT showing up in your search results...

Secondly, for yuri and tentacles, are you sure the posts you're seeing are tagged with those tags? Some posts may simply be missing the proper tags, or you may be expecting shoujo_ai posts to be tagged yuri.

*Edit: And yaoi is banned here, so if you're seeing posts you think should be tagged yaoi, they are probably just shounen_ai.
No, I'm quite sure. This image for example pops up in the search result.

post #242257

And it is tagged as yuri.

Any solution ?
The list you posted above is EXACTLY as it appears in your blacklist? Each tag is on a separate line and there are no uppercase characters? You made sure to click save before running the search?
Yes, I made sure of all that. This is the same blacklist I copied from danbooru and it works fine there.
Then I don't know. I just copied that list into my blacklist and tried it. It's working for me.

*Edit: Try clearing your cache or test with a different browser.
So it's only me that is experiencing this problem ? Strange.

The image I posted above doesn't appear in your search result then ?

Also, I just clicked on "Advanced Search" and it said "Not working yet!" below the Blacklist option. My account is new, does this have anything to do with that ?
That option in advanced search is just a separate feature that was never really implemented. It's probably for including a blacklist specific to the single advanced search you're performing and thus wouldn't affect your main blacklist.

Try clearing your cache or test with a different browser. Do you still have the same problem?
Tried with Firefox and didn't work.

Cleared the cache and that didn't work either.
Re-open your settings page and see if the tags still appear in your blacklist. If not, they may have been cleared somehow or never saved properly.

If the tags do appear, clear the list completely and re-type the valid tags manually. An invalid whitespace or zero-width character may have somehow ended up in there.

If it still won't work after that, I probably can't help you.
OK, so clearing the list and typing the tags manually actually worked. Thank you for the help.

But does this mean that the blacklist I use in danbooru is not compatible with this site ? Since the blacklist that didn't work was copied 1-to-1 from danbooru.
As I said earlier, three of those tags don't exist on this site. So they shouldn't really do anything here. But there shouldn't have been any harm in leaving them in.

When I copied the list you posted above into my blacklist, it worked fine. So the list itself is compatible. I don't know what went wrong. Your list might have somehow been corrupted on the server and just needed to be re-saved. Or maybe you somehow copied in an invalid character (like a unicode whitespace or zero-width character).

You could always test by copying the list from danbooru again. If it stops working again, just clear it and re-type it again.